anafranil online
IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Keep getting a collision warning, Keep getting a collision warning
Bob Gray
post Apr 29 2014, 05:24 AM
Post #1


Advanced Member
***

Group: Members
Posts: 33
Joined: 22-January 14
Member No.: 3,592



I keep getting a collision warming. I've looked at the simulation but do not see a problem. See attached file
Attached File(s)
Attached File  Counter_Back_Plate_01.zip ( 273.62K ) Number of downloads: 5
 
Go to the top of the page
 
+Quote Post
Sprut_UK
post Apr 29 2014, 06:22 AM
Post #2


Advanced Member
***

Group: Administrators
Posts: 1,091
Joined: 12-December 07
From: United Kingdom
Member No.: 4



Hi Bob,

There are a couple of small problems with the model that are the cause of the collision warning(s).

I ran the Simulation with 'Stop on collision' enabled, this showed that there was a collision, see the attached image 'Collision1.png'.
Looking at the model I can see that there are a couple of drilled holes that go through the part but they are modelled as 'blind' holes, see the attached image 'Collision2.png'.
Note: the problem area(s) have a mottled appearance, this is SprutCAM telling us that it thinks that these problem faces are on the 'inside' rather than the 'outside' of the part.

To solve it, I would simply delete the problem faces, re-sew the model (Model mode) and then recalculate the toolpaths.

I hope this helps?

Dave
Attached File(s)
Attached File  Collision1.png ( 28.4K ) Number of downloads: 18
Attached File  Collision2.png ( 54.49K ) Number of downloads: 16
 


--------------------
"Never interrupt your opponent when he is making a mistake..." - Napoleon Bonaparte
www.sprut.co.uk
Go to the top of the page
 
+Quote Post
danh818
post Apr 29 2014, 07:13 AM
Post #3


Member
**

Group: Members
Posts: 18
Joined: 15-September 12
From: Southern California
Member No.: 3,448



Bob, I suspect that the gouging is due to the construction of the model. If the bottom level is set above the height of the cross holes of the two large bosses, then there is no error. It looks like the ends of those holes terminate in a 'zero thickness' surface that could be causing the issue.

**Edit** Beaten to it by Dave
Go to the top of the page
 
+Quote Post
jim
post May 25 2014, 02:59 PM
Post #4


Member
**

Group: Members
Posts: 13
Joined: 27-December 12
Member No.: 3,496



Attached File  Walkway_wing.stc ( 1.39MB ) Number of downloads: 1



Rather than start a new thread I though I would use this one as itís a similar problem. I am getting green ticks when I generate the paths. But when I run the simulation I get a crash. What I donít understand is itís about an inch up in free air?

On a related issue I would like the tool to plunge away from the stock box edge. Itís been a while so I am relearning stuff I have forgot but I am sure you can do something with approach to sort that?


For some reason I could not upload a WinRAR file hence the big attachment?

Jim
Go to the top of the page
 
+Quote Post
Sprut_UK
post May 25 2014, 05:01 PM
Post #5


Advanced Member
***

Group: Administrators
Posts: 1,091
Joined: 12-December 07
From: United Kingdom
Member No.: 4



The collision was a machine collision warning. You can either turn off the 'Detect machine collisions' warning option, or, move the unused A axis out of the way and change the 'Current workpiece holder' to 'Fixed table'.

There is no plunge into the workpiece that I can see. In the attached modified version of your project I have changed the 'Max plunge angle' for the tool to 0 (degrees) and no plunges were shown upon simulation.
I have also selected the 'Use fast calculation method' because (I think) this gives a better result.

Please attach compressed files in 'zip' format as this is recognized by the forum software.

I hope this helps?

Dave
Attached File(s)
Attached File  Walkway_wing_dp.zip ( 415.08K ) Number of downloads: 2
Attached File  25_05_2014_17_51_06.jpg ( 50.6K ) Number of downloads: 10
Attached File  25_05_2014_17_51_29.jpg ( 8.15K ) Number of downloads: 7
Attached File  25_05_2014_18_05_44.jpg ( 17.44K ) Number of downloads: 9
Attached File  25_05_2014_18_09_20.jpg ( 41.88K ) Number of downloads: 8
 


--------------------
"Never interrupt your opponent when he is making a mistake..." - Napoleon Bonaparte
www.sprut.co.uk
Go to the top of the page
 
+Quote Post
jim
post May 29 2014, 09:09 PM
Post #6


Member
**

Group: Members
Posts: 13
Joined: 27-December 12
Member No.: 3,496



QUOTE (Sprut_UK @ May 25 2014, 06:01 PM) *
The collision was a machine collision warning. You can either turn off the 'Detect machine collisions' warning option, or, move the unused A axis out of the way and change the 'Current workpiece holder' to 'Fixed table'.

There is no plunge into the workpiece that I can see. In the attached modified version of your project I have changed the 'Max plunge angle' for the tool to 0 (degrees) and no plunges were shown upon simulation.
I have also selected the 'Use fast calculation method' because (I think) this gives a better result.

Please attach compressed files in 'zip' format as this is recognized by the forum software.

I hope this helps?

Dave



Worked a treat Dave
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 18th July 2019 - 12:28 AM